Onion Omega2 Debugger

Current setup
Dovre-Management
– Used as Wifi to Ethernet bridge for controlling devices on a lan without wireless
– IP/TCP Serial gateway
– TCP Port 4999 for Serial 1
– TCP Port 5000 for Serial 2
– NO DHCP enabled
– Omega2 Management IP Address
– IP: 172.31.100.254
– NetMask: 255.255.255.0
– Gateway: No Gateway
– Wireless is password protected

Dovre-Airplay
– Used for AirPlay playback
– DHCP Enabled
– Using 10.0.0.x subnet
– Lease starts at 10.0.0.50
– Lease ends at 10.0.0.200
– Omega2 Airplay IP Address
– IP: 10.0.0.254
– NetMask: 255.255.255.0
– Gateway: 10.0.0.254
– DNS: 10.0.0.254

Config files for the Omega 2

DHCP
config dnsmasq
option domainneeded ‘1’
option boguspriv ‘1’
option filterwin2k ‘0’
option localise_queries ‘1’
option rebind_protection ‘1’
option rebind_localhost ‘1’
option local ‘/lan/’
option domain ‘lan’
option expandhosts ‘1’
option nonegcache ‘0’
option authoritative ‘1’
option readethers ‘1’
option leasefile ‘/tmp/dhcp.leases’
option resolvfile ‘/tmp/resolv.conf.auto’
option localservice ‘1’

config dhcp ‘wwan’
option interface ‘wwan’
option ignore ‘1’

config odhcpd ‘odhcpd’
option maindhcp ‘0’
option leasefile ‘/tmp/hosts/odhcpd’
option leasetrigger ‘/usr/sbin/odhcpd-update’

config dhcp ‘airplay’
option interface ‘airplay’
option start ’50’
option limit ‘200’
option leasetime ‘1h’
option ra1 ‘server’

Network
config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘fd1d:48c4:7633::/48’

config interface ‘wlan’
option type ‘bridge’
option ifname ‘eth0’
option _orig_ifname ‘eth0 ra0’
option _orig_bridge ‘true’
option proto ‘static’
option ipaddr ‘172.31.100.254’
option netmask ‘255.255.255.0’
option ip6assign ’60’

config interface ‘airplay’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘10.0.0.254’
option _orig_ifname ‘ra1’
option netmask ‘255.255.255.0’
option ifname ‘ra1’

config route ‘airplayroute’
option interface ‘airplay’
option target ‘224.0.0.0’
option netmask ‘224.0.0.0’

Wireless
config wifi-device ‘ra0’
option type ‘ralink’
option mode ‘9’
option channel ‘auto’
option txpower ’15’
option htmode ‘HT20’
option country ‘US’
option disabled ‘0’

config wifi-iface
option device ‘ra0’
option network ‘wlan’
option mode ‘ap’
option encryption ‘psk2’
option key ‘Hidden for Obvious Reasons’ #####REMEMBER TO RENAME######
option ssid ‘Dovre-Management’

config wifi-iface
option device ‘ra0’
option mode ‘ap’
option network ‘airplay’
option ssid ‘Dovre-Airplay’
option encryption ‘none’

Sharp LC-70LE960X

TCP Connection
Port: 10002

Notes: To control this screen over IP you need to send the RSPW2 which enables IP control so that the screen dosent kill the LAN port when it powers off. It also requres 8 bytes being sent with a delimiter . So if the command being sent is 5 bytes then you will have to use 3 spaces.
Typically ” ” and then

Power On

POWR1   <cr>

Power Off

POWR0   <cr>

Turn On IP Power Control

RSPW2   <cr>

How to setup Wifi on Raspberry Pi

First do a search for wlans in the area with
sudo iwlist wlan0 scan

then open up wpa_supplicant.confg with

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

At the bottom of the file add this

network={
ssid="Your SSID"
psk=Your wifi password"
}

To reload the wpa config file do a sudo ifdown wlan0 and then a sudo ifup wlan0

Verify that everything is working with sudo ifconfig

Sony Bravia 2015

Sony Bravia Ip Control
Port: 20060

Power On

*SCPOWR0000000000000001<lf>

Power Off

*SCPOWR0000000000000000<lf>

Notes:

In order to enable this protocol, the following settings need to be enabled.
Settings > Network > Home network setup > Remote device/Renderer > Remote device/Renderer
Settings > Network > Home network setup > IP control > Simple IP Control

BRAVIA_B2B_RS232C_Protocol_Manual_v1.1
BRAVIA_B2B_SimpleIPControlProtocol_ForAndroidModels_v0.9